Author Topic: Katana 50 (MKI) connection problem  (Read 3042 times)

0 Members and 1 Guest are viewing this topic.

Offline nellicus

  • School Prom Hero
  • **
  • Posts: 48
  • Good Vibes 0
Katana 50 (MKI) connection problem
« on: October 11, 2019, 09:57:26 am »
Hi all,

I just (stupidly) upgraded my Mac to MacOS Catalina v10.15.....no whenever I try to connect Tone Studio to my Katana 50 I get an error saying Katana connection failure.
I don't use Tone Studio much but it was working before.
Anyone else experienced this issue, or have upgraded and it works fine?
I have reinstalled the drivers and it makes no difference.

Any help appreciated.
Thanks
Neil
--------------------------------------------------------------------------------
Electric - MIA Performer Strat HSS, Boss Katana 50. Acoustic - Eastcoast D2SE

Offline Majik

  • Stadium Superstar
  • ******
  • Posts: 2202
  • Good Vibes 154
Re: Katana 50 (MKI) connection problem
« Reply #1 on: October 11, 2019, 11:47:31 am »
Unfortunately, there are widespread compatibility issues with Catalina, and practically every pro-audio manufacturer has indicated compatibility issues.

https://www.pro-tools-expert.com/production-expert-1/2019/9/18/brands-are-already-issuing-warnings-about-not-upgrading-to-macos-catalina

Boss, specifically, have said:

“If you are using a Roland product via a USB connection to a Mac computer, please refrain from upgrading to macOS Catalina (macOS 10.15), which is about to be newly released. Compatibility with macOS Catalina (macOS 10.15) will be verified and announced after the release of macOS Catalina (macOS 10.15).

It sounds, to me, like you may have to wait until they release compatible drivers.

That's not very helpful, I know, but it may serve as a warning to others.

Cheers,

Keith

Sent from my Pixel 3 using Tapatalk

Guitars: PRS Singlecut S2, Fender Tele Lite Ash, G&L Legacy Tribute, Freshman Apollo 2 OCBX, Gibson SG Special P90
Amps: Bugera G5 Head, Boss Katana 100
All sorts of other stuff.

Offline nellicus

  • School Prom Hero
  • **
  • Posts: 48
  • Good Vibes 0
Re: Katana 50 (MKI) connection problem
« Reply #2 on: October 11, 2019, 03:34:15 pm »
Thanks for the quick reply Keith,

At least I'm not going crazy :-)
--------------------------------------------------------------------------------
Electric - MIA Performer Strat HSS, Boss Katana 50. Acoustic - Eastcoast D2SE

Offline nellicus

  • School Prom Hero
  • **
  • Posts: 48
  • Good Vibes 0
Re: Katana 50 (MKI) connection problem
« Reply #3 on: October 31, 2019, 11:32:40 am »
If anyone is interested the 10.15 driver for the Katana 50 MkI is now on the Boss website....havent got round to seeing if it works yet.........
--------------------------------------------------------------------------------
Electric - MIA Performer Strat HSS, Boss Katana 50. Acoustic - Eastcoast D2SE

Offline JetCityCobra

  • Pub Night Playa
  • ***
  • Posts: 137
  • Good Vibes 5
  • No time like the present
Re: Katana 50 (MKI) connection problem
« Reply #4 on: January 28, 2020, 03:48:57 am »
If anyone has figured out how to get this working yet with Catalina, Boss, and Version 4, I'd be extremely grateful if you could point me to the solution.

Frustrated. Buy a "Quality Piece of Kit" and they go and ruin it....
Breedlove Oregon Concert CE Sitka Spruce - Myrtlewood
Fender Mod Shop Telecaster
Fender Player Jazz Bass

Offline Libitina

  • Pub Night Playa
  • ***
  • Posts: 150
  • Good Vibes 5
  • Do something new, Learn the Guitar.
    • Libi's-Learning-Guitar
Re: Katana 50 (MKI) connection problem
« Reply #5 on: January 28, 2020, 02:10:46 pm »
There's also a problem with USB 3 port, I don't know if it applies to MK1 though.

Libi
1st, Epiphone Electro-acoustic AJ 220 SCE
2nd, Squire Strat HSS Candy Apple Red
3rd, Epiphone Ltd Ed. ES339 Vintage Sunburst

 

Get The Forum As A Mobile App