Justin Guitar Community

Tools of the Trade => Computer and OS => Topic started by: snuff on July 02, 2016, 07:43:26 pm

Title: Website on an android device.
Post by: snuff on July 02, 2016, 07:43:26 pm
Greetings,
When I open Justin's website on my phone or tablet it opens it from February the 20th. That is the last updates are from February and the header bar has all the Xmas songs on. The side headings are also missing.  It works fine on my computer just not on my devices and it doesn't matter how I open then, straight from Google or from the link from the forum page (which I can use as normal). Anybody any clues?  Both android by the way.
Thanks.
Title: Re: Website on an android device.
Post by: stitch101 on July 02, 2016, 08:14:14 pm
Have you tried clearing your cache?







Title: Re: Website on an android device.
Post by: snuff on July 02, 2016, 08:39:35 pm
Only had the tablet a month. Did it from the first.
Just tried clearing but still the same. A bit of a puzzler.
Title: Re: Website on an android device.
Post by: shadowscott007 on July 03, 2016, 02:03:43 am
My phone has the same issue.  My tablet does not.  Both Samsung.  Both Android.

Shadow
Title: Re: Website on an android device.
Post by: TB-AV on July 04, 2016, 03:35:39 am
Same here for my S7. But if you scroll down to the videos they are up to the minute. In fact one was just posted an hour ago.

Title: Re: Website on an android device.
Post by: snuff on July 05, 2016, 08:59:45 am
The last video on mine is stand by me. At least I'm not on my own with this.
Title: Re: Website on an android device.
Post by: Dan Graves on July 11, 2016, 03:06:04 am
Simple question : are you using a browser or some sort of app ?
If it's a browser, which one, if it's an app, same question.
Title: Re: Website on an android device.
Post by: snuff on July 11, 2016, 08:38:36 am
Chrome browser and the Google app. Does the same with both.
Title: Re: Website on an android device.
Post by: shadowscott007 on July 11, 2016, 09:52:15 am
Chrome on both.  Works on tablet, broke on phone.
Title: Re: Website on an android device.
Post by: Dan Graves on July 12, 2016, 06:23:16 pm
Hmm, Android version numbers/names ?
And @ shadow : if i may venture a guess, your tablet has a different android version than your phone ?
Title: Re: Website on an android device.
Post by: shadowscott007 on July 12, 2016, 06:30:29 pm
Yep.  Different.  Phone is probably newer...

I will have to dig and see which is what, Blueberry Fluffery, Chocolate Covered Butterfly or whatever...

but later...

Shadow
Title: Re: Website on an android device.
Post by: shadowscott007 on July 12, 2016, 08:40:08 pm
Okay, the Phone - that does not work - is Android version 6.0.1 Marshmallow which I believe is the latest and

Will check the Tablet - that works -  when I get home, but I think it is 4.?.?....

The last "Latest Lesson Updates" I have on the Phone is Stand By Me Ben E King February 26, 2016...

And I found this on the web:

"Samsung Electronics plan to provide the Android 6.0 Marshmallow update starting with Galaxy S6 and Galaxy S6 edge on February 15, 2016, and other GALAXY devices will soon follow.  For upgradable models, Samsung will make separate announcements on details of OS updates schedule for each market according to market situation and carriers’ requirements."

The highlighted date is suspiciously close to the I got broke timeframe....
Title: Re: Website on an android device.
Post by: snuff on July 12, 2016, 09:01:04 pm
Android 5.1 on an Acer tablet.
Title: Re: Website on an android device.
Post by: shadowscott007 on July 12, 2016, 10:37:55 pm
My working tablet is Android 4.4.2
Title: Re: Website on an android device.
Post by: Dan Graves on July 12, 2016, 11:11:52 pm
Well with that data in mind, i'll run a quick test with some emulators, having a phone on 4.4.2 myself i can test that part on my own, and then try some of the 5.x and 6.x versions on an emulator.
Might take me a day or so, so please, keep calm (and grow chillies).
Title: Re: Website on an android device.
Post by: Dan Graves on July 13, 2016, 08:54:07 pm
Results so far : Adroid 4.x.x versions all seem to have this issue for me when using Chrome or Firefox, 5.x has it as well.
I haven't found a working, clean build of 6.x yet so i will get back to you on that, although i suspect it won't be much different.
I suspect the issue is with how the site's mobile version detects browsers and/or how it redirects users, as requesting the desktop version of the site fixes the issue entirely for me on all versions, and in both Firefox and Chrome.

@ snuff : I couldn't for the life of me find any apps related to Justin's site, other than his metronome app...
Are you perhaps using Tapatalk ?

In any case, i've asked Justin on Twitter if he could get his webmaster to look at it, let's hope they can fix it.
Title: Re: Website on an android device.
Post by: snuff on July 13, 2016, 09:16:39 pm
Thanks for your time Dan.
The app I meant was the Google browser. The confusion is all mine.
Title: Re: Website on an android device.
Post by: Dan Graves on July 15, 2016, 03:14:55 am
Aaaaah, well that explains that.
But yeah, the issue isn't so much with Android as it seems to be with how the site renders when it detects it's on a mobile device.
I suspect Shadow's tablet doesn't pretend to be a mobile device, or the browser on it doesn't request the mobile version of the site, resulting in him getting the regular old website instead of the mobile one.
I hope Justin will see my tweet and point his webmaster this way, as this isn't something we users can fix.
Title: Re: Website on an android device.
Post by: justinguitar on July 16, 2016, 07:59:27 pm
Hey Dan. Sorry I missed ur tweet. I've asked my web assistant to have a look and see what she can figure out. Because we're about to embark on massive cms rebuild I'm reluctant to spend a lot of time (money) on it...

So the problem is the requests from Android devices running chrome - they're not getting the mobile versions? is that it in a nutshell?

Thanks for getting my attention on it!

J.
Title: Re: Website on an android device.
Post by: Dan Graves on July 17, 2016, 02:41:29 am
It's a bit more complicated than that i'm afraid.
If your web assistant requires an in-depth explanation they can feel free to send me a PM, or Email me at my @xs4all mail adress, from there they can decide if it's worth it to fix it now, or to wait (i suspect waiting would make more sense if you're doing a CMS rebuild).
Title: Re: Website on an android device.
Post by: Indigo on July 19, 2016, 08:57:33 am
Hi Dan, and others,
Thanks for reporting this :)

Is it just the latest songs that seem to be the problem?
I've now fixed this issue and you should now see the up to date latest releases.

Are there any other rendering issues you're experiencing? The mobile site will be getting a revamp soon, but if you are experiencing issues could you perhaps send me a screen grab of it?

Cheers
xx
Title: Re: Website on an android device.
Post by: snuff on July 19, 2016, 08:57:02 pm
Thanks. I'll try and send a screen shot.
Edit.  Just had a look and the latest songs are there. Thanks for your time in looking at it.
Big thumbs up.